View Single Post
Old 02-04-2009, 11:30 PM   #6
ktwo
Junior Member
ktwo began at the beginning.
 
Posts: 8
Karma: 10
Join Date: Feb 2009
Device: Sony PRS-500
Progress?

It seems I've had some progress. VirtualBox at least recognizes that the PRS-500 is plugged in . . .

Below is the output of the "VBoxManage list usbhost" on the host OS (Windows 7 (Beta)) . . .

VirtualBox Command Line Management Interface Version 2.1.2
(C) 2005-2009 Sun Microsystems, Inc.
All rights reserved.

Host USB Devices:

UUID: dbbffaf2-6b67-447a-aca7-2bfc8c5a4053
VendorId: 0x054c (054C)
ProductId: 0x029b (029B)
Revision: 1.0 (0100)
Manufacturer: Sony
Product: Sony Portable Reader System
Address: \\?\usb#vid_80ee&pid_cafe#6&ed52b26&0&2#{00873fdf-cafe-80ee-aa5e-00c04fb1720b}


So it would appear as if the guest OS (Windows XP) should be able to see the reader. But it's not. So more work . . .

Right now, the output of "prs500 info" and "prs500 df" give me the following error . . .

C:\Program Files\calibre>prs500 info
Traceback (most recent call last):
File "main.py", line 337, in <module>
File "main.py", line 208, in main
File "calibre\devices\prs500\driver.pyo", line 193, in __init__
File "calibre\devices\libusb.pyo", line 344, in get_device_by_id
File "calibre\devices\libusb.pyo", line 328, in busses
calibre.devices.libusb.Error: Could not find libusb.

C:\Program Files\calibre>prs500 info
Traceback (most recent call last):
File "main.py", line 337, in <module>
File "main.py", line 208, in main
File "calibre\devices\prs500\driver.pyo", line 193, in __init__
File "calibre\devices\libusb.pyo", line 344, in get_device_by_id
File "calibre\devices\libusb.pyo", line 328, in busses
calibre.devices.libusb.Error: Could not find libusb.


Any suggestions as to what is causing the errors?

-K2
ktwo is offline   Reply With Quote