Thread: Plugins
View Single Post
Old 01-03-2009, 12:21 PM   #1
junkml
Addict
junkml ought to be getting tired of karma fortunes by now.junkml ought to be getting tired of karma fortunes by now.junkml ought to be getting tired of karma fortunes by now.junkml ought to be getting tired of karma fortunes by now.junkml ought to be getting tired of karma fortunes by now.junkml ought to be getting tired of karma fortunes by now.junkml ought to be getting tired of karma fortunes by now.junkml ought to be getting tired of karma fortunes by now.junkml ought to be getting tired of karma fortunes by now.junkml ought to be getting tired of karma fortunes by now.junkml ought to be getting tired of karma fortunes by now.
 
junkml's Avatar
 
Posts: 277
Karma: 1004969
Join Date: Mar 2007
Device: Sony Reader
Plugins

Hello, I thought I'd start a new thread about the Plugins.

I've finally been able to create a plugin that will work with the Windows Command Line. However, I'm running into one thing.

If I modify the Hello World plugin to work on_import agains .lit files, I get the following error when loading a file:

Loading plugin from C:\Users\Owner\AppData\Roaming\calibre\plugins\Hel lo World Plugin.zip
Traceback (most recent call last):
File "C:\Program Files\calibre\library.zip\calibre\customize\ui.py" , line 146,
in _run_filetype_plugins
File "<string>", line 20, in run
File "calibre\ebooks\metadata\meta.pyo", line 87, in set_metadata
AttributeError: 'MetaInformation' object has no attribute 'lower'
junkml is offline   Reply With Quote