View Single Post
Old 10-13-2008, 03:10 AM   #1
angevin
Et In Arcadia Ego
angevin began at the beginning.
 
angevin's Avatar
 
Posts: 18
Karma: 10
Join Date: Dec 2007
Location: NewYork
Device: Sony prs-505
Calibre will build but won't install on bluewhite64 linux distro

Ok, I'm trying a new 64 bit distro since my last problem this one is called bluewhite64 linux (I was using slamd64 last time) :

Calibre will build just fine but I get this error message when installing calibre :

Quote:
Installed /usr/lib/python2.5/site-packages/calibre-0.4.95-py2.5-linux-x86_64.egg
Processing dependencies for calibre==0.4.95
Finished processing dependencies for calibre==0.4.95
Trying to setup udev rules...
Starting HAL daemon: /usr/sbin/hald --daemon=yes
Setting up bash completion... failed
Traceback (most recent call last):
File "build/bdist.linux-x86_64/egg/calibre/linux.py", line 170, in setup_completion
File "build/bdist.linux-x86_64/egg/calibre/gui2/lrf_renderer/main.py", line 1, in <module>
File "build/bdist.linux-x86_64/egg/calibre/gui2/library.py", line 18, in <module>
File "build/bdist.linux-x86_64/egg/calibre/library/database.py", line 6, in <module>
File "/usr/lib/python2.5/sqlite3/__init__.py", line 24, in <module>
from dbapi2 import *
File "/usr/lib/python2.5/sqlite3/dbapi2.py", line 27, in <module>
from _sqlite3 import *
ImportError: No module named _sqlite3
Traceback (most recent call last):
File "/usr/bin/calibre_postinstall", line 8, in <module>
load_entry_point('calibre==0.4.95', 'console_scripts', 'calibre_postinstall')()
File "build/bdist.linux-x86_64/egg/calibre/linux.py", line 440, in post_install
File "build/bdist.linux-x86_64/egg/calibre/linux.py", line 314, in setup_completion
UnboundLocalError: local variable 'manifest' referenced before assignment
Traceback (most recent call last):
File "setup.py", line 433, in <module>
subprocess.check_call('calibre_postinstall', shell=True)
File "/usr/lib/python2.5/subprocess.py", line 462, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command 'calibre_postinstall' returned non-zero exit status 1

Last edited by angevin; 10-13-2008 at 05:48 AM.
angevin is offline   Reply With Quote