View Single Post
Old 10-02-2008, 08:36 PM   #1
ould
Connoisseur
ould has a complete set of Star Wars action figures.ould has a complete set of Star Wars action figures.ould has a complete set of Star Wars action figures.ould has a complete set of Star Wars action figures.
 
Posts: 95
Karma: 399
Join Date: Sep 2008
Location: Toronto, Ontario
Device: Sony PRS-500
Calibre 0.4.89 won't start

Hi there,

I just upgraded my install to the latest version. I was previously running a bzr build from around the time of 0.4.83. Calibre attempts to start with the new version, asks for the folder where to store my books. When I select I briefly see the Calibre GUI window pop up but it disappears almost right away.

Console output:

Code:
Traceback (most recent call last):
  File "/usr/bin/calibre", line 8, in <module>
    load_entry_point('calibre==0.4.89', 'gui_scripts', 'calibre')()
  File "/usr/lib/python2.5/site-packages/calibre/gui2/main.py", line 1252, in main
    main = Main(single_instance, opts)
  File "/usr/lib/python2.5/site-packages/calibre/gui2/main.py", line 236, in __init__
    number_of_books = db.migrate_old(self.olddb, pd)
  File "/usr/lib/python2.5/site-packages/calibre/library/database2.py", line 999, in migrate_old
    self.conn.execute('INSERT INTO %s VALUES(%s)'%(table, ','.join(repeat('?', len(row)))), row)
sqlite3.IntegrityError: PRIMARY KEY must be unique
I can see that it doesn't like something about my old DB file. I tried moving the db file somewhere else and re-ran calibre but had a similar error so not sure what to think. This is on Linux btw.

Thanks,

Kevin
ould is offline   Reply With Quote