View Single Post
Old 04-29-2013, 11:53 AM   #1852
edwdecarlo
Enthusiast
edwdecarlo began at the beginning.
 
Posts: 35
Karma: 41
Join Date: Nov 2011
Location: North Kingstown, RI, USA
Device: Kindle DX,Fire HD
Quote:
Originally Posted by Greymage View Post
I just updated to latest calibre and kindle collections and am getting this error:

calibre, version 0.9.28
ERROR: Unhandled exception: <b>AttributeError</b>:CalibreInfo instance has no attribute 'kindle_model'

Traceback (most recent call last):
File "calibre_plugins.kindle_collections.ui", line 152, in customize
File "site-packages\calibre\customize\__init__.py", line 150, in do_user_config
File "calibre_plugins.kindle_collections.__init__", line 73, in config_widget
File "calibre_plugins.kindle_collections.customize" , line 46, in __init__
AttributeError: CalibreInfo instance has no attribute 'kindle_model'

It's an older kindle, not touch or paperwhite, and worked fine with this plugins last year. What should I look for?

calibre version 0.9.28
Kindle Collections 1.7.11 (30 Sep 2012)
I have the same versions of calibre and Kindle Collections. I just ran Kindle Collections against my Kindle Keyboard (pre touch and whitepaper) without any errors.

Perhaps you need to uninstall Kindle Collections plug-in and re-install it.

Another thing to consider, which version of calibre you were on prior to upgrading to 0.9.28. If it was a big enough jump, or you went from the 32-bit version to 64-bit version, you may need to uninstall calibre and re-install 0.9.28 again.

Another thing to look at is if you are using a Metadata Plugboard. I am and the Device is set to KINDLE2. Perhaps you have this set yours to something different; a change to calibre may have made the Device type more sensitive/critical.

I hope at least one of these are helpful, or point you into the correct direction.
edwdecarlo is offline