View Single Post
Old 04-22-2013, 03:14 PM   #21
DiapDealer
Grand Sorcerer
DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.
 
DiapDealer's Avatar
 
Posts: 8,752
Karma: 39457947
Join Date: Jan 2010
Device: Nexus 7, Kindle Fire HD
You beat me to it!

I was able to compile using the -mno-sse2 flag (just to be sure) after making changes similar to yours in the "sigil-0.7.2/src/src/Xerces/xercesc/util/Xerces_autoconf_config.hpp" file.
(I basically just downloaded the xerces source and ran configure using the --disable-sse2 switch to see what it produced, and then compared it to the source in Sigil)

No errors and it still runs on my machine, but I have no hardware that DOESN'T support SSE2 to truly test it on.

I created a patch to change those two files if it makes it any easier. Just drop it in the uppermost level of Sigil's source tree (sigil-0.7.2/src if you're using the official instructions), cd to that same location and issue:
Code:
patch -p1 < sigil-0.7.2-no-sse2.patch
before running cmake.
(I attached it as a txt file so it would let me upload it ... you can rename it to sigil-0.7.2-no-sse2.patch or modify the command accordingly.)
Attached Files
File Type: txt sigil-0.7.2-no-sse2.txt (1.8 KB, 36 views)

Last edited by DiapDealer; 04-22-2013 at 03:44 PM.
DiapDealer is offline   Reply With Quote