View Single Post
Old 02-28-2013, 02:57 PM   #14
Mrs_Often
Wizard
Mrs_Often ought to be getting tired of karma fortunes by now.Mrs_Often ought to be getting tired of karma fortunes by now.Mrs_Often ought to be getting tired of karma fortunes by now.Mrs_Often ought to be getting tired of karma fortunes by now.Mrs_Often ought to be getting tired of karma fortunes by now.Mrs_Often ought to be getting tired of karma fortunes by now.Mrs_Often ought to be getting tired of karma fortunes by now.Mrs_Often ought to be getting tired of karma fortunes by now.Mrs_Often ought to be getting tired of karma fortunes by now.Mrs_Often ought to be getting tired of karma fortunes by now.Mrs_Often ought to be getting tired of karma fortunes by now.
 
Mrs_Often's Avatar
 
Posts: 1,310
Karma: 1495609
Join Date: Dec 2011
Location: The Netherlands
Device: Kobo Touch, Kobo Glo
Quote:
Originally Posted by euro traveler View Post
Yes, the Kobo Mini's "nothing" space does indeed annoy me. It stays there even when I set the margins to "0". The side margins go to "0", but the bottom margin remains unchanged. I've figured out how to use Calibre to remove the CSS info and allow for margin and font adjustments of my epubs on the Kobo Mini, so that's not the problem.

Sometimes the Mini will surprise me and fill in some of that space.
It's not a margin thing. It's a layout thing where the reader decides to start a new paragraph on the next page to prevent 3 or less lines appearing "alone" of the beginning or end of a paragraph at the end of the page or the beginning of a new page respectively (see here for more explanation). The 3 lines are the standard in CSS settings. Maybe nice for non fiction and/or text books, but not for fiction.

Quote:
Originally Posted by Willa View Post
How/where do you do that?
You can manually set the orphan and widow values to 0, so that a paragraph will not start on the new page even if only one of the lines of the new paragraph would fit on the end of the page (or be left on its own on the next page). You have to set this each book separately:

Either have Calibre do it for you during the convert, by adding extra CSS code. See attachment.

Or if you don't want to do a full convert, you can add the CSS manually in Sigil or through the "Tweak book" and then "Explode" functions in Calibre.

In the book stylesheet.css (or other filename with .css), add some code into the body style (next to the other things that might already be there). Use a plain text editor and then save (and rebuild the book if you're using Calibre).
Code:
body {
	margin: 0px;
	widows: 0;
	orphans: 0;
	margin-top: 10pt;
}
The grey are not necessary, just examples of styles already present.


That'll fix the annoying gaps However, depending on your font and lineheight settings, there will still be a relatively large space between the text and the bottom of the screen, because the bottom menu space is always reserved and is rather big. If a letter that goes below baseline (like g or j) would only touch the top of the menu line the whole line of text would move to the next page. So, though the widows and orphans set to 0 gives a MUCH nicer screen fill, it's still not optimal in all cases (and even varies per page).

There might be a way to set the widows and orphans globally from within the .kobo/Kobo/Kobo eReader.conf file but it's not tested yet and uncertain if those options are listened to by Kobo.
Attached Thumbnails
Click image for larger version

Name:	cal2.png
Views:	73
Size:	281.3 KB
ID:	102118  
Mrs_Often is offline   Reply With Quote