View Single Post
Old 02-23-2013, 09:50 AM   #5
one_user
Junior Member
one_user began at the beginning.
 
Posts: 1
Karma: 10
Join Date: Feb 2013
Device: Kobo Glo
When I installed 2.4, all my sideloaded epubs (DRM-free) did not open. I got the same message "This document is not currently authorized for use with your Adobe ID. Please sign in and try again". Tried to restart, re-register, etc to no avail. I ended up downgrading to 2.1.5 and now I can read all my books.

IMHO, while the Kobo products are ok from a hardware perspective, I think that their firmware releases are not well tested and pretty buggy. They should concentrate at addressing annoying bugs before adding any new features.
one_user is offline   Reply With Quote