View Single Post
Old 02-16-2013, 09:04 AM   #20
fenuks
Enthusiast
fenuks began at the beginning.
 
Posts: 33
Karma: 10
Join Date: Aug 2011
Device: Amazon Kindle 3
I've prepared some updates and new recipes. zip. I have also updated Wprost and PC Lab recipes (didn't working at least few months, I'm not an author of these recipes).

Additionally there's a bug (I think) in calibre since 0.9.16. It's do not occur often, for now I noticed it only in one of recipes I made, named FilmWeb. Due this bug images are not downloaded. I've attached full logs in zip archive. Error message is as following:
Code:
Traceback (most recent call last):
  File "site-packages/calibre/web/fetch/simple.py", line 392, in process_images
TypeError: must be string, not None
.
Calibre v0.9.15 download FilmWeb recipe correctly and it (recipe) wasn't changed in calibre 0.9.15 or later versions.

Last thing: relative urls in articles.
Many pages uses relative urls, so if you want follow that link in downloaded ebook, ebook viewer will show an error message like this:
Code:
Unable to run the command specified. The file or folder file:///tmp/calibre_0.9.19_tmp_Fte5JQ/e7NVOt_ebook_iter//tmp/calibre_0.9.19_tmp_r4kWHA/3gABsQ_plumber/feed_0/article_0/index.xhtml does not exist.
It can be fixed by adding code to preprocess_html which adds index to these links, but for some reason it's not working for all recipes. I think it would be nice idea to add to calibre recipes API variable e.g. url_index and if it would be set, calibre would add this string to all relative links.
Thanks.
fenuks is offline   Reply With Quote