View Single Post
Old 01-22-2013, 09:32 PM   #5
latepaul
Fanatic
latepaul ought to be getting tired of karma fortunes by now.latepaul ought to be getting tired of karma fortunes by now.latepaul ought to be getting tired of karma fortunes by now.latepaul ought to be getting tired of karma fortunes by now.latepaul ought to be getting tired of karma fortunes by now.latepaul ought to be getting tired of karma fortunes by now.latepaul ought to be getting tired of karma fortunes by now.latepaul ought to be getting tired of karma fortunes by now.latepaul ought to be getting tired of karma fortunes by now.latepaul ought to be getting tired of karma fortunes by now.latepaul ought to be getting tired of karma fortunes by now.
 
latepaul's Avatar
 
Posts: 555
Karma: 3543210
Join Date: Dec 2011
Device: Kobo Touch, Kindle Touch, Kobo Mini, Kobo Aura HD, Nexus 7, Kindle PW2
Actually I'm only using Qt5 for building sigil, the default Qt is still the system version (4.8 I think). I only set the PATH for the session doing the build. Once it picks up the correct qmake cmake configures everything else.

I figured I was going to have to set LD_LIBRARY_PATH but found it worked even if I didn't and have found that the executable gets compiled with the full path to the library in it. If that path exists it uses it, otherwise it checks LD_LIBRARY_PATH. (I've seen this before and I can't remember if it's a particular compile flag but I don't think it does it by default.)

Of course setting LD_LIBRARY_PATH would be neater and 'safer' but it's handy not to have to.
latepaul is offline   Reply With Quote