View Single Post
Old 01-18-2013, 12:52 PM   #7
docthomas
Junior Member
docthomas began at the beginning.
 
Posts: 3
Karma: 10
Join Date: Jan 2013
Device: kindle
Quote:
Originally Posted by gkbeer View Post
That did it.

/etc/init.d/skeleton in Ubuntu 9.04 had more options in it that I needed.

Here is my final copy for others to reference.
You will need to edit it to change...
CONTENT=/home/glenn/Library to point to your library.

It goes in /etc/init.d and should be named calibre without the .txt.
In a terminal the following commands need to be run:

cd /etc/init.d
sudo chown root calibre
sudo chgrp root calibre
sudo chmod 755 calibre
sudo insserv calibre


Start/stop the calibre content server with:

sudo /etc/init.d/calibre start
sudo /etc/init.d/calibre stop


Note: don't forget to turn off starting the content server in Calibre's preferences.

I am having trouble using this method with an unbuntu 12.04 server. When I issue the sudo insserv calibre command I get:
sudo: inserv: command not found

I have searched but I cant seen to find an answer on why this fails. I am using the script that was attached to the thread.

Thanks for any help you can provide.
docthomas is offline   Reply With Quote