View Single Post
Old 08-21-2008, 08:48 AM   #3
Jellby
frumious Bandersnatch
Jellby ought to be getting tired of karma fortunes by now.Jellby ought to be getting tired of karma fortunes by now.Jellby ought to be getting tired of karma fortunes by now.Jellby ought to be getting tired of karma fortunes by now.Jellby ought to be getting tired of karma fortunes by now.Jellby ought to be getting tired of karma fortunes by now.Jellby ought to be getting tired of karma fortunes by now.Jellby ought to be getting tired of karma fortunes by now.Jellby ought to be getting tired of karma fortunes by now.Jellby ought to be getting tired of karma fortunes by now.Jellby ought to be getting tired of karma fortunes by now.
 
Jellby's Avatar
 
Posts: 5,790
Karma: 4027751
Join Date: Jan 2008
Location: Spaniard in Sweden
Device: Cybook Orizon
Well, I've reduced the example to this:

Code:
<HTML>
<HEAD>
</HEAD>
<BODY>
<P>J&rsquo;ai une excuse s&eacute;rieuse&nbsp;:</P>
<P>J&apos;ai une excuse s&eacute;rieuse&nbsp;:</P>
<P>J'ai une excuse s&eacute;rieuse&nbsp;:</P>
</BODY>
</HTML>
which, after converting to mobi and back to HTML gives:

Code:
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=windows-1252" />
</head>
<body>
<p>J&rsquo;ai une excuse s&eacute;rieuse :
<p>J'ai une excuse s&eacute;rieuse&nbsp;:
<p>J'ai une excuse s&eacute;rieuse&nbsp;:
</body>
</html>
The problem seems to be the "&rsquo;", which causes the "&nbsp;" to be converted to a space. The same happens with "&rdquo;", but not with "&raquo;". My guess is something is checking for balanced quote marks. I'd say this is a bug, anyway.
Jellby is online now   Reply With Quote