View Single Post
Old 01-09-2013, 09:39 AM   #45
entodoays
Zealot
entodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enough
 
entodoays's Avatar
 
Posts: 139
Karma: 706
Join Date: Oct 2011
Device: Sony Reader PRS-T1
I have more information. I tried to "restore" the backup I had done earlier (post #40) to a blank microSD card (not to the Reader). I was astonished to find out that the new partition table on the card was not identical to the Reader's partition table. There were at least 3 differences:
  1. The Reader partition table started with a 26Mb free space. This was not replicated on the restored card.
  2. The System partition was MISSING completely!
  3. The Data partition was also missing and, instead of these two partitions, I got unpartitioned space.
Could this point to a possible problem with the partition table on my Reader in the first place? I do have a separate disk image for each partition (not the initial free space though), but I'm afraid of doing anything, being afraid of bricking my Reader completely.

Furthermore, I have actually unrooted it again and tried, unsuccessfully, to do another backup. The backup would stop at 39 Mb, that is in the middle of the Diag partition. This is very worrying and I was ready to send it for repairs but I'm afraid that repairing it would cost too much (postage, repair, resend) so if anyone could give me a clue on what could be done (if there's anything that could be done) I would be very grateful.
entodoays is offline   Reply With Quote