View Single Post
Old 01-04-2013, 01:24 PM   #9
Ripplinger
350 Hoarder
Ripplinger ought to be getting tired of karma fortunes by now.Ripplinger ought to be getting tired of karma fortunes by now.Ripplinger ought to be getting tired of karma fortunes by now.Ripplinger ought to be getting tired of karma fortunes by now.Ripplinger ought to be getting tired of karma fortunes by now.Ripplinger ought to be getting tired of karma fortunes by now.Ripplinger ought to be getting tired of karma fortunes by now.Ripplinger ought to be getting tired of karma fortunes by now.Ripplinger ought to be getting tired of karma fortunes by now.Ripplinger ought to be getting tired of karma fortunes by now.Ripplinger ought to be getting tired of karma fortunes by now.
 
Ripplinger's Avatar
 
Posts: 2,022
Karma: 2233955
Join Date: Dec 2010
Location: Midwest USA
Device: Sony PRS-350: 3 Silver, 2 Blue!; Kobo Glo
Quote:
Originally Posted by JSWolf View Post
I have never had a problem with the image being 100% and this includes Bluefire and iBooks. What app/program are you using that causes a blank page with a 100% image height?
Using Sigil I've had it happen with just bad code on my first book, probably happened by just dragging the image onto the page. I originally thought having the image at 100% of the screensize was the issue, but that didn't fix it. My Sony displays at 800x600 pixels.

This code forced a blank page after the cover:
<body>
<p class="sgc-1"><img alt="" src="../Images/image001.jpg" />&nbsp;</p>
</body>

Removing the &nbsp; so that the code read like this also forced a blank page after the cover:
<body>
<p class="sgc-1"><img alt="" src="../Images/image001.jpg" /></p>
</body>

Changing to this fixed the problem:
<body>
<div>
<svg xmlns="http://www.w3.org/2000/svg" height="100%" version="1.1" viewBox="0 0 443 747" width="100%" xmlns:xlink="http://www.w3.org/1999/xlink">
<image height="800" width="475" xlink:href="../Images/cover.jpeg"></image>
</svg>
</div>
</body>

Btw, the "&nbsp; wasn't causing the blank page either, I even removed that at first thinking it was the problem, but even without it, it still always forced a blank page after the cover, and that blank page appeared in Calibre's viewer as well as on my ereader.

Last edited by Ripplinger; 01-07-2013 at 03:31 AM.
Ripplinger is offline   Reply With Quote