View Single Post
Old 12-28-2012, 08:40 AM   #66
Junior Member
floher began at the beginning.
Posts: 5
Karma: 10
Join Date: Dec 2012
Device: Kindle Paperwhite
Originally Posted by ciromattia View Post
I know, installing PIL is not funny at all, and this is the main point for I want to make a redistributable app via py2app.
In the meantime, you can look here for some hints; basicly you have to:
Install libjpeg
curl -O
tar -xvzf jpegsrc.v8c.tar.gz
cd jpeg-8c
sudo make install
cd ../
Install freetype
curl -O
tar -xvzf freetype-2.4.5.tar.gz
cd freetype-2.4.5
sudo make install
cd ../
and then install PIL.
As you get it installed, you should not have anymore that error.
Unrar and are included in the droplet, so you should not worry about missing them (I put them in requirements section for the bare python script users).
Let me know if it works!
Thanks for your quick response.
I actually found that exact same page and tried to enter the code (not knowing what it does, of course).
It starts working fine, but I get the first error when I get to the "./configure" command. It says "configure: error: no acceptable C compiler found in $PATH".
And then if I go with "make" on he simply outputs "-bash: make: command not found".

I simply entered line after line? Am I doing something wrong?

So I guess I need to get a C compiler (an acceptable one ) and put it somewhere?

Last edited by floher; 12-28-2012 at 08:43 AM.
floher is offline   Reply With Quote