View Single Post
Old 11-15-2012, 11:51 PM   #88
khseal
Enthusiast
khseal actually enjoys Vogon poetry.khseal actually enjoys Vogon poetry.khseal actually enjoys Vogon poetry.khseal actually enjoys Vogon poetry.khseal actually enjoys Vogon poetry.khseal actually enjoys Vogon poetry.khseal actually enjoys Vogon poetry.khseal actually enjoys Vogon poetry.khseal actually enjoys Vogon poetry.khseal actually enjoys Vogon poetry.khseal actually enjoys Vogon poetry.
 
Posts: 35
Karma: 56654
Join Date: Oct 2012
Location: Russia
Device: Kindle Touch
Quote:
root@kindle:/# apt-cache show gcc-4.7-base
Package: gcc-4.7-base
Status: ok installed
Priority: required
Section: libs
Installed-Size: 56
Maintainer: Debian GCC Maintainers <debian-gcc@lists.debian.org>
Architecture: armel
Source: gcc-4.7 (4.7.2-4em1)
Version: 4.7.2-4em1
Description: GCC, the GNU Compiler Collection (base package) (gripped)
This package contains files common to all languages and libraries
contained in the GNU Compiler Collection (GCC).
. ...

Package: gcc-4.7-base
Source: gcc-4.7
Version: 4.7.2-4
Installed-Size: 196
Maintainer: Debian GCC Maintainers <debian-gcc@lists.debian.org>
Architecture: armel
Breaks: dehydra (<= 0.9.hg20110609-2), gcj-4.4-base (<< 4.4.6-9~), gcj-4.6-base (<< 4.6.1-4~), gnat-4.4-base (<< 4.4.6-3~), gnat-4.6 (<< 4.6.1-5~)
Description-ru: GCC, набор компиляторов GNU (основной пакет)
Пакет содержит общие для всех языков и библиотек файлы набора компиляторов
GNU (GCC, GNU Compiler Collection).
Multi-Arch: same
Homepage: http://gcc.gnu.org/
Description-md5: b6e93638a6d08ea7a18929d7cf078e5d
Section: libs
Priority: required
Filename: pool/main/g/gcc-4.7/gcc-4.7-base_4.7.2-4_armel.deb
Size: 143344
MD5sum: 5ff457a69869d9957ea8f37dc63378d9
SHA1: bb8d9b2fb70289ddf75440cc9af2ca21406fbcf3
SHA256: f75e8225173bcec0e9c4fa5bdb7921fc17f94c1ca1faa0329b 6765d8725564f1
Strange Version: 4.7.2-4em1. I think a bug in versions.

Quote:
root@kindle:/# apt-get install cpp-4.7

The following packages have unmet dependencies:
cpp-4.7 : Depends: gcc-4.7-base (= 4.7.2-4) but 4.7.2-4em1 is to be installed
E: Unable to correct problems, you have held broken packages.

root@kindle:/# apt-get install gcc-4.7-base
Reading package lists... Done
Building dependency tree
Reading state information... Done
gcc-4.7-base is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
khseal is offline   Reply With Quote