View Single Post
Old 11-04-2012, 08:23 PM   #22
twobob
( ͡° ͜ʖ ͡°){ʇlnɐɟ ƃǝs}Týr
twobob ought to be getting tired of karma fortunes by now.twobob ought to be getting tired of karma fortunes by now.twobob ought to be getting tired of karma fortunes by now.twobob ought to be getting tired of karma fortunes by now.twobob ought to be getting tired of karma fortunes by now.twobob ought to be getting tired of karma fortunes by now.twobob ought to be getting tired of karma fortunes by now.twobob ought to be getting tired of karma fortunes by now.twobob ought to be getting tired of karma fortunes by now.twobob ought to be getting tired of karma fortunes by now.twobob ought to be getting tired of karma fortunes by now.
 
twobob's Avatar
 
Posts: 6,552
Karma: 6015922
Join Date: Jun 2012
Location: uti gratia usura (Yao ying da ying; Mo ying da yieng)
Device: PW-WIFI|K5-3G+WIFI| K4|K3-3G|DXG|K2| Rooted Nook Touch
EDIT: REMEMBER TO RUN:

/var/lib/dpkg/info/dash.preinst install

AND

dpkg --configure -a

apt-get install dialog locales

dpkg-reconfigure locales



TO PREVENT THE ISSUES OUTLINED HERE!
Spoiler:

---------------------------------------------------------
hmm adduser is unhappy.

I have no name!@kindle:/# groups
Quote:
groups: cannot find name for group ID 0
0
I have no name!@kindle:/# groupadd users
Quote:
groupadd: cannot open /etc/group
adduser: `/etc/adduser.conf' does not exist. Using defaults.
adduser: The GID 65534 does not exist.
I have no name!@kindle:/etc# touch /etc/group

I have no name!@kindle:/etc# adduser me
Quote:
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = "en_US.UTF-8",
LANG = "en_US.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
adduser: `/etc/adduser.conf' does not exist. Using defaults.
Adding user `me' ...
Adding new group `me' (1001) ...
Adding new user `me' (1000) with group `me' ...
useradd: cannot open /etc/passwd
I have no name!@kindle:/etc# touch /etc/passwd
I have no name!@kindle:/etc# /usr/sbin/useradd -d /home/me -g me -s /bin/bash -u 1000 me

I have no name!@kindle:/etc# login
Quote:
login: PAM Failure, aborting: Critical error - immediate abort
errr.... I'll google it

I have no name!@kindle:/etc# ldd /bin/login | grep libpam.so
Quote:
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
libpam.so.0 => /lib/arm-linux-gnueabi/libpam.so.0 (0x40002000)
hmm well I read http://content.hccfl.edu/pollock/AUnix2/PAM-Help.htm and am still non the wiser. I'll come back to it tomorrow now I think.

Last edited by twobob; 11-21-2012 at 10:14 PM.
twobob is offline   Reply With Quote