View Single Post
Old 10-26-2012, 11:18 AM   #152
vlad59
Addict
vlad59 can name that ebook in five wordsvlad59 can name that ebook in five wordsvlad59 can name that ebook in five wordsvlad59 can name that ebook in five wordsvlad59 can name that ebook in five wordsvlad59 can name that ebook in five wordsvlad59 can name that ebook in five wordsvlad59 can name that ebook in five wordsvlad59 can name that ebook in five wordsvlad59 can name that ebook in five wordsvlad59 can name that ebook in five words
 
Posts: 352
Karma: 37761
Join Date: Sep 2011
Device: Kobo eReader Touch, Kobo Aura HD
Quote:
Originally Posted by Northguy View Post
@Vlad:

Sorry for the late reply. I was kind of busy with other stuff like work, family, etc
No problem, real life always comes first !

Quote:
Originally Posted by Northguy View Post
I Tested the new version with your suggestions. On my Synology DS212+ (DSM 4.0-2198)

Open_Base_Dir:
Good suggestion. I removed my mount point and I can access the database outside the webroot without problems. I get a list of books and I can zoom into the metadata for details.

With respect to downloading I have less good results. My findings:
1) When requesting a list of books I get an overview with titles, accompanied with a cover photo on the left hand side.
2) When selecting the Photo to get a detailed view in the fancyapps I only get a window stating "The requested content cannot be loaded. Please try again later".
3) When fetching a fancybox for the book details, the stylesheet is still not working properly. Text is flowing outside the fancebox.
4) When fetching a book in the way suggested by you the PRS-T1 downloads "fetch.php itself in stead of the book.
5) When fetching a book through a regular browser (IE9 on Win7) I download the proper title "bookname.epub" but the file has a 0kb file size.

It surprises me that you manage to download files with X-Sendfile, because (to my limited knowledge) this package is not included in the standard Apache webserver of the Synology.
1) So it's OK
2) Strange it really worked out of the box for me
3) I've not the problem on my Kobo, I'll check if there may be something fishy !
4) So I guess that Calibre library is outside the web directory. I had the same problem on my Kobo and added cops_use_url_rewriting for this. But I have not checked it on my NAS, I will test this weekend and report here.
5) That part is really strange, I really cannot reproduce your problem.

About X-Sendfile, I really don't know if my NAS uses it (there is no log available). But download works if I enable it.
vlad59 is offline   Reply With Quote