View Single Post
Old 10-24-2012, 03:10 PM   #1
Syx
Junior Member
Syx began at the beginning.
 
Posts: 4
Karma: 10
Join Date: May 2012
Device: Kindle 3
[Old Thread] Strange Calibre portable Issue

Hello,
i have a strange issue in Calibre portable > 0.9.0, in 0.8.x i don't have the problem.

Context :
i use Calibre for manage my comcis/bs/manga collection, when i import a new comix the first image became the cover.
My calibre installation are placed on my NAS and i execute calibre from my cifs share.

extension type : pdf, cbr and cbz

Problem :
if i add a new book just after upgrade the cover generation i ok. but if i close Calibre and re-execute then the generation of cover failed. (and the fix cover in edit metadata don't work too).
in debug mode i have this error :
calibre Journal de débogage
calibre 0.9.3 Portable
Windows-7-6.1.7601-SP1 Windows
('Windows', '7', '6.1.7601')
Python 2.7.3
Windows: ('7', '6.1.7601', 'SP1', 'Multiprocessor Free')
Starting up...
Key u'A' for shortcut Ajouter des fichiers aux références de livres selectionnées is already used by Ajouter des livres, ignoring
Key u'F3' for shortcut Aller à l’article précédent is already used by Aller à la prochaine correspondance, ignoring
Key u'Alt+T' for shortcut Basculer Navigateur d’étiquettes is already used by Livres avec les mêmes étiquettes, ignoring
Key u'Ctrl+F' for shortcut Lancer la recherche is already used by Recherche avancée, ignoring
Key u'Alt+S' for shortcut Lancer la recherche is already used by Livres dans cette série, ignoring
Started up in 23.78 seconds with 3595 books
Worker Launch took: 0.34299993515
Job: 1 Read metadata (0 of 1) finished
Read metadata (0 of 1)

Traceback (most recent call last):
File "site-packages\calibre\library\database2.py", line 3362, in create_book_entry
File "site-packages\calibre\library\database2.py", line 1169, in set_cover
File "site-packages\calibre\utils\magick\draw.py", line 71, in save_cover_data_to
File "site-packages\calibre\utils\magick\draw.py", line 20, in _data_to_image
File "site-packages\calibre\utils\magick\__init__.py", line 132, in load
Exception: no decode delegate for this image format `' @ error/blob.c/BlobToImage/360
Added 1234 to db in: 6.39600014687 seconds

if i re-install Calibre the first execution work but all other don't generate cover ... is really strange
Someone have the same problem ? and maybe a solution ?

thanks (and sorry for horrible English )
Syx is offline   Reply With Quote