View Single Post
Old 10-22-2012, 10:40 PM   #15
davidfor
Wizard
davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.
 
Posts: 4,816
Karma: 4772844
Join Date: Jul 2011
Location: Australia
Device: Kobo Touch, Kobo Glo
Quote:
Originally Posted by michelar View Post
Well, after a lot of test this is what i discovered.

Now i have two pc with calibre on
On the first one i have 0.9.3
On the second one i have 0.9.1

1)With 0.9.3 i put a book on the device, everythink is ok (library and
device info shows the green check)

I close calibre and reopen it
The book are not visible in the device tab nor in library tab (no green check)
That is what is expected. The driver is only checking what is the device has in its internal database and not looking at the file system. Only after disconnecting the device and having it process the new book will calibre also see it.
Quote:
unplugging the usb or restart the device does not change anything. i tried also a pc restart
When you disconnected the device, did it process the new book and show it in the home screen or the library list?
Quote:
After that I connect my device to 0.9.1 and.... I see my book on the
device (not in the library because the library is not update)

I close calibre, unplug the device

Now when i connect my device to 0.9.3 I can see the book on my device but not in the library (no green check on LIBRARY)
OK, that is broken. And I have a couple of reports of similar looking problems but under different circumstances.
Quote:
I saved all the files metadata.calibre and driveinfo.calibre and i see that after sending the book the metadata.calibre is full with a lot of strange character
The metadata.calibre that you attached looks fine. Looking at it, the first few books are kepubs, so they shouldn't match with anything in your calibre library.

The last book is the problem. The title is "Il posto di ognuno - 7". Is that exactly what is displayed in the calibre library? And what does the device show on its library list?

Could you also try sending a book from calibre whose title and title sort are identical? That means it can't start with an article such as "Il" or "The" or "A" for English. I'm curious about whether that will work properly.
Quote:
I attach the file after insert a book. Do you think my library is corrupted ?
No, I don't think so. It looks like a bug in the driver.
Quote:
Tomorrow i will try to uninstall calibre and reinstall it.
Don't bother. I'm pretty sure it is a bug in the driver and I will look at it.

Last edited by davidfor; 10-22-2012 at 10:49 PM. Reason: fixed some tags
davidfor is offline   Reply With Quote