View Single Post
Old 10-22-2012, 05:51 PM   #62
SIRSteiner
Linuxfreak
SIRSteiner ought to be getting tired of karma fortunes by now.SIRSteiner ought to be getting tired of karma fortunes by now.SIRSteiner ought to be getting tired of karma fortunes by now.SIRSteiner ought to be getting tired of karma fortunes by now.SIRSteiner ought to be getting tired of karma fortunes by now.SIRSteiner ought to be getting tired of karma fortunes by now.SIRSteiner ought to be getting tired of karma fortunes by now.SIRSteiner ought to be getting tired of karma fortunes by now.SIRSteiner ought to be getting tired of karma fortunes by now.SIRSteiner ought to be getting tired of karma fortunes by now.SIRSteiner ought to be getting tired of karma fortunes by now.
 
SIRSteiner's Avatar
 
Posts: 374
Karma: 221896
Join Date: Aug 2012
Location: Germany, Saxony
Device: Kobo Touch, PocketBook Touch 622, PocketBook Touch Lux 623
Themes funktionieren mit neuer Firmware NICHT

Hallo liebe Leser,

ich habe eine 4er Test-Firmware im Zusammenhang mit meinen Themes getestet. Dabei habe ich folgendes festgestellt:

  1. Die Crystal-Themes könnte ich anpassen. So wie sie sind, wären sie nicht brauchbar für die (wahrscheinlich) kommende Version.
  2. Die Classic-Themes funktionieren überhaupt nicht, d.h. Der Bildschirmaufbau ist zwar vorhanden, aber man kann die Widgets, also die Inhalte, nicht konfigurieren. Ursache hier sind ganz einfach die im System fehlenden Widgets unter /ebrmain/widgets. Dies ist sehr schade, denn mir ist es auch nicht gelungen die "alten" Widgets mit Tricks in das entsprechende Verzeichnis zu kopieren, da hier nur "root" Schreibberechtigung hat, meine Scripte aber als Benutzer "sreader" ausgeführt werden. Ein "sudo" schlug auch fehl. Abgesehen davon ist fraglich, ob sie überhaupt funktionieren würden.
Fazit: Wer auf die Classic-Themes nicht verzichten möchte und sonst glücklich ist, der sollte sich das kommende Update nicht installieren.

Vielleicht schaut ja mal Forkosigan vorbei und kann etwas dazu beitragen oder etwas dafür tun, dass die Widgets wieder aufgenommen werden. Bisher hat er leider auf meine PNs nicht geantwortet.

Eventuell macht es ja Sinn, dass alle "Classic"-Fans ihren Wunsch nach Unterstützung seitens PocketBook hier kund zu tun. Ich finde diese Art des Startmenüs jedenfalls als Aufwertung.

Übrigens: Wer dennoch die kommende Firmware testen möchte, der kann immerhin auf die Version 3.2.108 downgraden (mit <-Taste und >-Taste halten beim booten). Damit funktionieren die Themes wieder, u.U. aber erst nach einem kleinen Eingriff in eine bestimmte Konfigurationsdatei (default_map.cfg in der Tiefe des Profilordners: driver.0.map=lastopen, driver.1.map=mainmenu).

Und noch was: Auch die von mir getestete Version hat nur dieses eine "Contrast"-Theme an Bord. Warum nutzt PocketBook nicht das Potential der User und baut die Themes aus? Sollte dies ein PocketBook-Mitarbeiter lesen: Gegen eine kleine Spende würde ich die Themes an die neue Version anpassen, wenn die Voraussetzungen vorhanden sind. Ich hätte dann nichts gegen eine feste Integration in der Firmware. Im russischen Forum habe ich mittlerweile (soweit mir möglich war) gelesen, dass auch hier das Classic-Theme verwendet wird.

Und nun als letztes: Weiß eigentlich jemand, ob ein Werksreset auch die Firmware zurücksetzt wie beim Kobo Touch? Nachdem meine grauen Haare schon mehr wurden bei dem Gedanken, eventuell nicht downgraden zu können, habe ich das Werksreset nicht noch testen wollen.

Viele Grüße
Ronny
SIRSteiner is offline   Reply With Quote