View Single Post
Old 10-05-2012, 01:08 PM   #16
chaley
"chaley", not "charley"
chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.
 
Posts: 5,255
Karma: 821512
Join Date: Jan 2010
Location: France
Device: Many android devices
Quote:
Originally Posted by manxam View Post
I was an early adopter of the original beta but didn't partake in this test though. Up until now everything has worked perfectly.

I just downloaded 2.2.1 and the new Calibre .9.1 for OSX and now when trying to connect wirelessly CC is telling me that another device is connecting to Calibre and that I should disconnect it first. There are no other wireless devices that I have ever used with calibre.

Any ideas?

Thanks!

EDIT: Ok, figured THAT one out. I was charging my android cell phone which is an MTP device on the laptop. While OSX didn't detect it and Calibre didn't connect to it AND it didn't show up as a wireless device (obviously) and DOESN'T have CC installed on it.. CC would NOT connect with it plugged in. This is likely a failure with Calibre and not CC though. Even after unplugging the phone I could not connect until I restarted calibre.

As a note, I had restarted Calibre a few times with the phone plugged in so that wasn't the issue, it was definitely the phone and the new MTP driver. Weird!
I think that our calibre wireless connection driver might be deciding too quickly that another device is connected. When CC connects, our driver waits for a time for calibre to begin the connection process. If calibre does not do that, then we assume it is servicing another device. If, however, calibre is trying to connect to an MTP device that isn't rapidly responding, the time limit might pass before calibre responds to CC. I will look for a way around this.

One thing you can do that I think would help is to tell the MTP driver to ignore your phone. I think you do his by plugging in your phone then going to preferences -> plugins -> device interface plugins -> MTP and then "blacklisting" your phone. If you never want any MTP device to connect then you can disable the MTP plugin, but that might be too big a hammer.
chaley is offline   Reply With Quote