View Single Post
Old 10-01-2012, 03:42 AM   #8
chaley
"chaley", not "charley"
chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.
 
Posts: 5,783
Karma: 1212746
Join Date: Jan 2010
Location: France
Device: Many android devices
Quote:
Originally Posted by deb27 View Post
Actually, the basic wifi functions on the android tablet work fine. Email, browsing etc. (yes it would be somewhat useless if that didn't work).

But unfortunately Calibre Companion isn't the same animal. It's relying on IP address and ports and I suspect that's where the problem is. I am not using static IP addresses (too many devices in the house I'd have to mess with to get everyone set up as static) so the IP address on my PC changes.
Yes, I've checked the IP. I know what the address is. I've gone into Calibre and have set the wireless device connection Ip and port. And I've gone into CC and set the identical values. But when I tell CC to connect it keeps telling me that the IP address is wrong.
There is a mystery here. You should not need to enter an IP address or a port into CC, especially because you are running windows. The only thing that might throw a spanner into the works is if you are running a third-party firewall that does port blocking instead of application blocking. In this case none of the auto-connect techniques will work and you would need to enter an IP address into CC.

My suspicion is that you were running a version of calibre that did not support the improvements we made to CC & calibre to help CC find calibre. Those improvements appeared in calibre 0.8.67, two versions after CC support was first introduced in calibre.
Quote:
I uninstalled the CC ap, and reinstalled it and started over again. It finally connected via wifi. But I've done this before. By tomorrow it will have quit working again. That's why I wanted to switch to wired. Then I don't have to deal with IP addresses, ports, wireless etc.
I hope that you upgrading calibre to 0.9 will fix the connection problem. Please let me know. We really want connecting to "just work", and if there is something about your network that prevents that, then I want to try to understand what it is and to find a way to work around it. I realize that I am asking for your time, and will totally understand if you have reached your limit.

In any event, theducks suggestion is a good one, and one that I have used for many years. If you set up a static lease on your router (in the DHCP section), then in effect the computer with the MAC address in the lease has a fixed IP address but doesn't know it. No parameters are changed on the computer. I do this for all our desktop computers because it makes sharing over the network easier (somewhat faster recognition that the computer has been turned on). I also do it for main router, our secondary wireless access point, our NAS (Network Accessible Storage) boxes, and our network VoIP box to make connecting to their web admin interface easier. I find it much easier to set up static leases than to fight with each device's configuration options.

I don't bother for our laptops or phones, or with computers brought in by our friends when they visit.
chaley is offline   Reply With Quote