View Single Post
Old 09-30-2012, 02:05 PM   #26
Kaylee Skylyn
Enthusiast
Kaylee Skylyn has become a pillar of the MobileRead communityKaylee Skylyn has become a pillar of the MobileRead communityKaylee Skylyn has become a pillar of the MobileRead communityKaylee Skylyn has become a pillar of the MobileRead communityKaylee Skylyn has become a pillar of the MobileRead communityKaylee Skylyn has become a pillar of the MobileRead communityKaylee Skylyn has become a pillar of the MobileRead communityKaylee Skylyn has become a pillar of the MobileRead communityKaylee Skylyn has become a pillar of the MobileRead communityKaylee Skylyn has become a pillar of the MobileRead communityKaylee Skylyn has become a pillar of the MobileRead community
 
Posts: 38
Karma: 15790
Join Date: Feb 2012
Device: android phone, Sony PRS 350
I was having similar issue but once one of the height="100%" width="100%" was removed it works fine. In my situation the images are all wider than tall so I removed the height="100%" from the code and it works fine on my Sony and Aldiko android app.
I think...can't find the right code at the moment....

I think this is the code that worked for me...For the opening banner, as it was much wider than tall:
Code:
<div class="cenimage">
    <svg style="max-width:576px; max-height:288px" xmlns="http://www.w3.org/2000/svg" width="100%" preserveAspectRatio="xMidYMid meet" version="1.1" viewBox="0 0 576 288" xmlns:xlink="http://www.w3.org/1999/xlink" >
      <image height="288" width="576" xlink:href="images/masterpostbanner-1.png" ></image>
    </svg>
</div>
Where the div is just:
Code:
div.cenimage {text-align: center;}

Last edited by Kaylee Skylyn; 09-30-2012 at 02:18 PM.
Kaylee Skylyn is offline   Reply With Quote