View Single Post
Old 09-29-2012, 09:30 AM   #16
edebill
Junior Member
edebill began at the beginning.
 
Posts: 6
Karma: 10
Join Date: May 2011
Device: kindle paperwhite, kobo mini, kobo aura hd, nexus 5, nexus 7, ipad air
My apologies fo the slow reply. For some reason I was expecting an email notification that I'd gotten a reply. Now I know.

Quote:
Originally Posted by chaley View Post
The best guess I can make is that some security setting is preventing your Mac from using multicast. Why this would be I cannot say. Alternatively, the Bonjour components might not be installed. This would surprise me given that Bonjour is Apple-made, but I suppose it is possible. Last idea: port 9004 might be somehow reserved and unusable with bonjour.
/sbin/ifconfig shows only a single IP, with multicast enabled. There are about 6 other network devices, but none of them have an IPv4 address. I tried enabling IPv6 on my home network recently, but I think that was mainly a base station change.

en1: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULT ICAST> mtu 1500
ether f8:1e:df:db:9c:33
inet6 fe80::fa1e:dfff:fedb:9c33%en1 prefixlen 64 scopeid 0x5
inet 172.16.1.10 netmask 0xffffff00 broadcast 172.16.1.255
media: autoselect
status: active

I made sure the firewall was off. I checked netstat for any other apps set to the same port number, but didn't find any.

Changing the port to 9004, 9091 and 12345 didn't seem to make a difference.


Quote:
Originally Posted by chaley View Post
Thinking about it, the wireless system can work even if bonjour registration is not successful. I will change the driver not to give up in this case. The change won't appear in a release for a week unless you run from source.
I assume that means I'll need to specify the computer's IP address in the Calibre Companion app. That's not as convenient, but if it's a choice between typing in an IP address and not having it work, I know what I'll choose

Thanks,
Erik
edebill is offline   Reply With Quote