View Single Post
Old 09-20-2012, 12:49 AM   #18
knc1
Embedded Cheerleader
knc1 ought to be getting tired of karma fortunes by now.knc1 ought to be getting tired of karma fortunes by now.knc1 ought to be getting tired of karma fortunes by now.knc1 ought to be getting tired of karma fortunes by now.knc1 ought to be getting tired of karma fortunes by now.knc1 ought to be getting tired of karma fortunes by now.knc1 ought to be getting tired of karma fortunes by now.knc1 ought to be getting tired of karma fortunes by now.knc1 ought to be getting tired of karma fortunes by now.knc1 ought to be getting tired of karma fortunes by now.knc1 ought to be getting tired of karma fortunes by now.
 
knc1's Avatar
 
Posts: 6,192
Karma: 5830426
Join Date: Feb 2012
Device: Too many.
Quote:
Originally Posted by megacoupe View Post
1. Did you modify the USB/RS232 TTL adapter in any way? Can you describe which terminals/wires you connected to which plates on the serial port? (My current setup, from left to right, is: 1=5V 2=TXD 3=RXD 4=Ground)
  • Do not try to power the adapter from the Kindle!
  • The Kindle interface is 1.8 volt and will not tolerate 5.0 or 3.3 volt interfaces. Translation: Do not be surprised if the serial interface port is now fried.
  • Option your adapter to take its power from the USB side of the cable if it is not already configured that way.
Translation:
Connect ONLY the Tx, Rx and Gnd leads!
.
Inspect the board at the pad areas.
Using a very bright light to penetrate the green protective masking helps.

What you are looking for is the pad which is connected to the very large area "shadow" - THAT pad is the "Gnd" connection.

Now you are down to two wires and three pads.

On the SoC in the DX and DXG only the USB downloader mode uses:
57500,8,n,2

On the DX, DXG both U-Boot and the kernel serial console uses:
115000,8,n,1

All other Kindle models use only 115000,8,n,1

Using ONLY the lead marked "Rx" from the adapter (which you now have optioned for 1.8 volt operation - see above) as a test probe ;

With your terminal emulator running, already configured for the proper line speed conditions ;
(Doing this first prevents any of the setup command and initialization commands from reaching the Kindle.)

Connect your "test probe" lead to one of the remaining three pads ;
Restart the kindle ;
Do you see readable characters in the terminal emulator?
  • NO: Try the next un-tried pad - repeat the "Restart Kindle" step.
  • YES: That is the proper connection point for the "Rx" lead.
This leaves you with two pads and one wire.
Have just verified the connection points for the first two wires.

Without connecting the last wire, type characters into the terminal emulator ;
Do you see the characters on the emulator screen?
  • YES: Disable the "character echo" in the emulator.
  • NO: Continue to next step.
Of the two unidentified pads left, try connecting the remaining lead to the pad immediately adjacent to the pad which has the "Rx" lead connected to it. That one is most likely to be correct.

Now (with the Kindle running normally - not asleep or halted - restart it if not sure) :
Type on the terminal - Do you see the characters echoed on the screen now?
  • YES: That is the proper place for the last of the THREE wire interface connection.
  • NO: Try the last remaining pad.
If the last remaining pad does not show the characters echoed, yet you can see the messages being sent from the Kindle port - -
Then your SoC serial port is damaged, put it back together, send it back to Amazon - the device is not repairable.

Note: I have over 60 years of hands on experience with electronic hardware, the above will work if nothing has been damaged.

Last edited by knc1; 09-20-2012 at 12:58 AM.
knc1 is offline   Reply With Quote