View Single Post
Old 09-19-2012, 02:59 AM   #446
DoctorOhh
US Navy, Retired
DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.
 
DoctorOhh's Avatar
 
Posts: 8,809
Karma: 12535517
Join Date: Feb 2009
Location: North Carolina
Device: Nexus 7
Quote:
Originally Posted by BetterRed View Post
I can run into the situation where the group includes several of these 'slow' books. The plug-in spawns up to 5 instances of calibre-parallel. When this happens my computer becomes practically unusable for an unacceptable period (my patience ran out after 33 minutes); because 4 of the calibre-parallel processes are EACH consuming 24.n% of a CPU core, totalling ~ 98% of the entire CPU
Why they are taking up so much cpu time is immaterial if you want to fix it go to Preferences - Behavior and change Job priority from Normal to Low then restart calibre. This will ensure your computer is responsive to you and the calibre-parallel processes will cede to you when you want to do something other than stare at the computer.

Quote:
Originally Posted by BetterRed View Post
I'll try starting calibre via the start command with the affinity switch set at 2, theoretically that should limit calibre to 2 cores only
You can also control cpu cores via Preferences - Miscellaneous, but once you change Job priority you should be fine.
DoctorOhh is offline   Reply With Quote