View Single Post
Old 09-10-2012, 07:51 AM   #4
Man Eating Duck
Addict
Man Eating Duck juggles neatly with hedgehogs.Man Eating Duck juggles neatly with hedgehogs.Man Eating Duck juggles neatly with hedgehogs.Man Eating Duck juggles neatly with hedgehogs.Man Eating Duck juggles neatly with hedgehogs.Man Eating Duck juggles neatly with hedgehogs.Man Eating Duck juggles neatly with hedgehogs.Man Eating Duck juggles neatly with hedgehogs.Man Eating Duck juggles neatly with hedgehogs.Man Eating Duck juggles neatly with hedgehogs.Man Eating Duck juggles neatly with hedgehogs.
 
Posts: 252
Karma: 69784
Join Date: May 2006
Location: Oslo, Norway
Device: Kobo Aura, Sony PRS-650
Quote:
Originally Posted by ceryta87 View Post
Hi,

I am new to using Calibre and could use some help please. I don't know if I am asking in the section or if this has already been covered. My problem is that I added all my books around 1700, so far so good. But than I noticed in the author column that the names listed different ways. Some of the names were FIRST LAST and others were LAST, FIRST. How do I get them to all go the same way? It is creating two seperate folders for the same author. I click on the authors tab, and than manager authors, and than "copy all author sort to author" but it is not working. thanks for any help.
As travger says, you're better off staying away from the folders

For the author sort trick to work, you need to specify 'comma' as the author sort calculation method under Preferences -> Tweaks -> "Author sort name algorithm". Then you recalculate all in Manage authors, and copy all author sort values to author. This will give you "Last, First" in most cases, although it might fail on auhtors with more than two names. You should of course make a backup of the library before doing this (as with all major operations).
Man Eating Duck is offline   Reply With Quote