View Single Post
Old 09-06-2012, 03:09 PM   #1
frymaster
Junior Member
frymaster began at the beginning.
 
Posts: 4
Karma: 10
Join Date: Sep 2012
Device: cybook odyssey
corrupt filesystem, no books show up.

my first e-book reader (and my first post here!) and already i've got serious problems with my e-book reader. i've attempted to contact bookeen directly with this issue, but it's been days and i've heard nothing back.

The first symptom is that books added to the Odyssey do not appear in the library. It appears this problem is caused by a corrupt filesystem. I have attempted to put books on my Odyssey three ways.
1) Mount to the filesystem on Arch Linux
2) Mount to the filesystem under Windows XP
2) Use Calibre under Windows XP

Connecting to Linux (Arch)
Initially I attempted to mount the Odyssey under Arch Linux. The device was recognized, however no filesystem was apparent.

Code:
# dmesg | tail
[69585.519879] usbcore: registered new interface driver usb-storage
[69585.519881] USB Mass Storage support registered.
[69586.523707] scsi 4:0:0:0: Direct-Access     Bookeen  Flash Disk       0316 PQ: 0 ANSI: 2
[69586.525946] scsi 4:0:0:1: Direct-Access     Bookeen  Flash Disk       0316 PQ: 0 ANSI: 2
[69586.529818] sd 4:0:0:0: [sdb] Attached SCSI removable disk
[69586.534586] sd 4:0:0:1: [sdc] Attached SCSI removable disk
[69588.956446] sd 4:0:0:0: [sdb] 2698920 512-byte logical blocks: (1.38 GB/1.28 GiB)
[69588.957316] sd 4:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[69588.968824]  sdb
lsusb shows that the device is there...

Code:
lsusb
Bus 002 Device 002: ID 0525:a4a5 Netchip Technology, Inc. Linux-USB File Storage Gadget
I mounted the raw device /dev/sdb and attempted to see if it was accessible

Code:
mount /dev/sdb /mnt/bookeen 

ls -lh /mnt/bookeen/
ls: cannot access /mnt/bookeen/Fonts: Input/output error
ls: cannot access /mnt/bookeen/Music: Input/output error
total 104K
drwxr-xr-x   4 root root 4.0K Aug  3 16:01 Digital Editions
d?????????   ? ?    ?       ?            ? Fonts
d?????????   ? ?    ?       ?            ? Music
-rwxr-xr-x   1 root root  214 May 29 00:00 autorun.inf
-rwxr-xr-x   1 root root  278 Sep  2 19:00 driveinfo.calibre
-rwxr-xr-x   1 root root  12K Sep  2 19:00 metadata.calibre
drwxr-xr-x 625 root root  80K Sep  3 01:39 system
Copying any files to any directory on the mounted Odyssey produced only Input/output error warnings.

I attempted fsck to investigate

Code:
# umount /dev/sdb
# fsck /dev/sdb
fsck from util-linux 2.21.2
dosfsck 3.0.12, 29 Oct 2011, FAT32, LFN
There are differences between boot sector and its backup.
Differences: (offset:original/backup)
  65:01/00
1) Copy original to backup
2) Copy backup to original
3) No action
This response from fsck caused me concern. I exited fsck without doing any repair.

Code:
# umount /dev/sdb
On the Odyssey I did the "Advanced/Reinitialization" procedure and tried to mount on Linux again with the same results.


Connecting to Windows XP

Tethered the Odyssey to Windows XP. The Odyssey presented as drive E: in "my computer".

Opening E: and attempting to copy a file to the the device gave error message "the file or directory is corrupted and unreadable"

In "My Computer", right clicking on E; and selecting "open as portable media device" allowed my to copy files into
- Root directory (E: drive)
- "Digital Editions" folder (e:\Digital Editions)

Unmounted the Odyssey and unplugged it. The added ebook did not show up in the Library under either the normal view or the folder view


Connecting with Calibre on Windows XP

Installed Calibre and configured it for "Cybook Odyssey". Plugged in the Odyssey.

Added epub book using "send to device/send to main memory"

Pulled menu option to "show books in the main memory of this device" to confirm calibre saw that the book was on the Odyssey. Calibre showed the book.

Selected menu opeion "eject this device" and unplugged cybook

No books shown in library under either regular view or folder view

Ran "reinitialization" on Odyssey

No books shown in library under either regular view or folder view

Plugged Odyssey back into Windows XP machine and relaunched Calibre

Pulled menu option to "show books in the main memory of this device" to confirm the book added is listed there. Calibre showed the book as being on the Odyssey. However, no books are visible in the Odyssey's Library under either regular or folder view.

Current situation.
- No books show in the Library at all, not even the ones that shipped with the device.

- the Library Folder view shows one Folder labelled "Cybook 01/01/1970". This date makes me think something is wrong with the Library management as it is a date view of 0 in a unix timestamp.

- I started up a wifi connection and not been prompted to upgrade firmware

Any help in resolving this situation is greatly appreciated!

note that i have linux, windows xp and an os x computer... and i'm willing to use any of them to solve this!
frymaster is offline   Reply With Quote