View Single Post
Old 08-31-2012, 05:41 AM   #4
Jellby
frumious Bandersnatch
Jellby ought to be getting tired of karma fortunes by now.Jellby ought to be getting tired of karma fortunes by now.Jellby ought to be getting tired of karma fortunes by now.Jellby ought to be getting tired of karma fortunes by now.Jellby ought to be getting tired of karma fortunes by now.Jellby ought to be getting tired of karma fortunes by now.Jellby ought to be getting tired of karma fortunes by now.Jellby ought to be getting tired of karma fortunes by now.Jellby ought to be getting tired of karma fortunes by now.Jellby ought to be getting tired of karma fortunes by now.Jellby ought to be getting tired of karma fortunes by now.
 
Jellby's Avatar
 
Posts: 6,193
Karma: 4800739
Join Date: Jan 2008
Location: Spaniard in Sweden
Device: Cybook Orizon, Kobo Aura
Thanks for finding a case where it works, it made me investigate a bit deeper... and my conclusion is that the thin no-break space works if it is defined in the font. My default font is Minion Pro Caption, and I thought it included the thin space, but it does not. (ADE 1.8 seems to perform character substitution when the font does not have the right one, that's why it works fine in the Orizon with hyphenation enabled).

So, I've made a test. I've modified Minion Pro Caption (already with several kerning modifications) to include the #8239 character, embedded it in a French book, and it works nicely in ADE 1.7 (under Wine). The font in the Éfélé book is weird, it's probably a subset, but FontForge does not open it correctly (the characters don't match their names).

To add the #8239 character, just open your font in FontForge, select the space character (#32, before the !), copy it (Ctrl+C), go to #8239 (View -> Go to, write 8239), paste (Ctrl+V), double-click the character and drag the vertical line somewhat to the left, to make the space narrower. I believe the non-breaking property is implicit, but maybe something else should be done.
Jellby is online now   Reply With Quote