View Single Post
Old 08-17-2012, 07:58 AM   #1683
cmcanulty
Junior Member
cmcanulty began at the beginning.
 
Posts: 8
Karma: 10
Join Date: Mar 2010
Device: none
patch error

When I try to load the patch in plugins I get this error
calibre, version 0.8.38
ERROR: Unhandled exception: <b>InvalidPlugin</b>:The plugin in u'/home/cmcanulty/Documents/eBookReader/kcoll_touch_tweaks-v9.patch.zip' is invalid. It does not contain a top-level __init__.py file

Traceback (most recent call last):
File "/usr/lib/calibre/calibre/gui2/preferences/plugins.py", line 306, in add_plugin
plugin = add_plugin(path)
File "/usr/lib/calibre/calibre/customize/ui.py", line 339, in add_plugin
plugin = load_plugin(path_to_zip_file)
File "/usr/lib/calibre/calibre/customize/ui.py", line 54, in load_plugin
return loader.load(path_to_zip_file)
File "/usr/lib/calibre/calibre/customize/zipplugin.py", line 160, in load
plugin_name = self._locate_code(zf, path_to_zip_file)
File "/usr/lib/calibre/calibre/customize/zipplugin.py", line 255, in _locate_code
% path_to_zip_file)
InvalidPlugin: The plugin in u'/home/cmcanulty/Documents/eBookReader/kcoll_touch_tweaks-v9.patch.zip' is invalid. It does not contain a top-level __init__.py file
cmcanulty is offline   Reply With Quote