View Single Post
Old 06-15-2012, 05:44 AM   #13
mwyoung
MWYoung
mwyoung began at the beginning.
 
Posts: 3
Karma: 10
Join Date: Jun 2012
Device: none
Hi folks,

Total noob to calibre and python and just about everything these days. Been at war for 20 years and just got back and discovered calibre for the thousands (I'm NOT kidding) of books on my various computers (9).

Now, I'm attempting(!) to put all my books in one place and get them all in the same format--I don't care which format...(Oh, ya, that's gonna happen)

However, I attempted to install your plugin (Mobi_Unpack_v050.zip) to calibre v0.8.56 (current version and by the usual install method) and got back the following:

(open quote)
calibre, version 0.8.56
ERROR: Unhandled exception: <b>InvalidPlugin</b>:The plugin in u'C:/Program Files/Calibre2/plugins2/Mobi_Unpack_v050.zip' is invalid. It does not contain a top-level __init__.py file

Traceback (most recent call last):
File "site-packages\calibre\gui2\preferences\plugins.py", line 306, in add_plugin
File "site-packages\calibre\customize\ui.py", line 339, in add_plugin
File "site-packages\calibre\customize\ui.py", line 54, in load_plugin
File "site-packages\calibre\customize\zipplugin.py", line 160, in load
File "site-packages\calibre\customize\zipplugin.py", line 255, in _locate_code
InvalidPlugin: The plugin in u'C:/Program Files/Calibre2/plugins2/Mobi_Unpack_v050.zip' is invalid. It does not contain a top-level __init__.py file
(close quote)

I'm pretty sure calibre had me in mind when it generated this error...you know, book library trials and tribulations and all that (ISBN or LOCCN ordering?).

Please relate to me what I've done wrong (this time!) and correct my bad behavior, please...

TIA
Mwyoung
mwyoung is offline   Reply With Quote