View Single Post
Old 04-26-2012, 12:14 AM   #352
KevinH
Guru
KevinH ought to be getting tired of karma fortunes by now.KevinH ought to be getting tired of karma fortunes by now.KevinH ought to be getting tired of karma fortunes by now.KevinH ought to be getting tired of karma fortunes by now.KevinH ought to be getting tired of karma fortunes by now.KevinH ought to be getting tired of karma fortunes by now.KevinH ought to be getting tired of karma fortunes by now.KevinH ought to be getting tired of karma fortunes by now.KevinH ought to be getting tired of karma fortunes by now.KevinH ought to be getting tired of karma fortunes by now.KevinH ought to be getting tired of karma fortunes by now.
 
Posts: 749
Karma: 285540
Join Date: Nov 2009
Device: many
Hi,

Simply run Mobi_Unpack on the split .azw3 file and examine the Log to see if the fonts were properly included or not. Perhaps the fonts were encrypted? Either way, unpack it and look to see what is up. If there is a bug, let me know here.

ps.
I can not recreate this issue ... I have tried it with various kindlgen generated sample files that have fonts and all of the fonts were properly included in the split version of the file.

So I need more here if you wan to get this bug fixed.


Quote:
Originally Posted by xxy View Post
Great job, Kevin. It's just getting better and better. I have previously generated a mobi file with embedded fonts using kindlegen 2.4. Now there seems a problem after unpacking and splitting into a mobi7 and a azw3 (KF8) file. The azw3 file can be opened by Kindle Touch but there's no embedded fonts any more. It might due to the lack of declaration of the fonts information in the manifest section of opf, I guess.

Last edited by KevinH; 04-26-2012 at 04:02 PM. Reason: added request for more info here
KevinH is offline   Reply With Quote