View Single Post
Old 04-14-2012, 07:16 AM   #28
ixtab
0x2A
ixtab ought to be getting tired of karma fortunes by now.ixtab ought to be getting tired of karma fortunes by now.ixtab ought to be getting tired of karma fortunes by now.ixtab ought to be getting tired of karma fortunes by now.ixtab ought to be getting tired of karma fortunes by now.ixtab ought to be getting tired of karma fortunes by now.ixtab ought to be getting tired of karma fortunes by now.ixtab ought to be getting tired of karma fortunes by now.ixtab ought to be getting tired of karma fortunes by now.ixtab ought to be getting tired of karma fortunes by now.ixtab ought to be getting tired of karma fortunes by now.
 
ixtab's Avatar
 
Posts: 2,903
Karma: 6677427
Join Date: Dec 2011
Device: K3, K4, K5, KPW, KPW2
With 5.1.0, the manifest of the apps is REQUIRED to contain "Extension-List" and related attributes.

See lines 24-26 of https://bitbucket.org/ixtab/ktfontha...a5f1/build.xml for an example.

Note: the Specification-Version should probably be "2.0" (or even less) for downward-compatibility. 2.0 is KT Firmware 5.0.*, I don't know about older Kindles. For this particular software, I set it to 2.1 specifically because I DO NOT want the software to work on FW 5.0.*.

As far as I know, this is the only change that is required. I have successfully run fonthack on 5.1.0 by simply adding these attributes to the manifest.

Last edited by ixtab; 04-14-2012 at 07:19 AM.
ixtab is offline   Reply With Quote