Thread: NetConnect
View Single Post
Old 03-30-2012, 09:04 PM   #8
rkomar
Wizard
rkomar ought to be getting tired of karma fortunes by now.rkomar ought to be getting tired of karma fortunes by now.rkomar ought to be getting tired of karma fortunes by now.rkomar ought to be getting tired of karma fortunes by now.rkomar ought to be getting tired of karma fortunes by now.rkomar ought to be getting tired of karma fortunes by now.rkomar ought to be getting tired of karma fortunes by now.rkomar ought to be getting tired of karma fortunes by now.rkomar ought to be getting tired of karma fortunes by now.rkomar ought to be getting tired of karma fortunes by now.rkomar ought to be getting tired of karma fortunes by now.
 
Posts: 1,769
Karma: 4368476
Join Date: Oct 2010
Location: Vancouver, BC, Canada
Device: PRS-505, PB 902, PRS-T1, PB 623, PB 840
Quote:
Originally Posted by alcuin View Post
You are right, if I build EABI, my application runs outside of the chroot, and everything works. On the other hand, my SDK was not outdated: I was just using the latest version found on the official site (http://pocketbook-free.sourceforge.net/en/sdk.shtml) of the non-pro SDK. So the solution is: for 360+ use the pro SDK!
That site looks to be out of date. Look here: http://sourceforge.net/projects/pocketbook-free/. You will also see the dates on when the files were uploaded. The non-Pro SDK is over two years old.

It is also a misnomer to label the latest SDKs as being for Pro devices only. You can build for both EABI and OABi using the new SDKs. The newer devices use the Freescale part of the SDK (arm-none-linux-gnueabi), and the older ones use the PBSDK part (arm-linux; OABI). So do yourself a favour and forget about the old SDK version; it will only give you headaches.

Edit: Oh and welcome to MobileRead! I hope you will contribute to the PocketBook software projects found here.

Last edited by rkomar; 03-30-2012 at 09:07 PM.
rkomar is online now   Reply With Quote