Thread: Tools fastboot for win32
View Single Post
Old 03-12-2012, 09:20 AM   #17
geekmaster
Всё гениальное просто.
geekmaster ought to be getting tired of karma fortunes by now.geekmaster ought to be getting tired of karma fortunes by now.geekmaster ought to be getting tired of karma fortunes by now.geekmaster ought to be getting tired of karma fortunes by now.geekmaster ought to be getting tired of karma fortunes by now.geekmaster ought to be getting tired of karma fortunes by now.geekmaster ought to be getting tired of karma fortunes by now.geekmaster ought to be getting tired of karma fortunes by now.geekmaster ought to be getting tired of karma fortunes by now.geekmaster ought to be getting tired of karma fortunes by now.geekmaster ought to be getting tired of karma fortunes by now.
 
geekmaster's Avatar
 
Posts: 5,069
Karma: 6789001
Join Date: Nov 2011
Location: Щедрость не имеет пределов.
Device: *.*
Quote:
Originally Posted by hostar View Post
I'm proudly present working and tested fastboot for Windows.
Tested by rewriting diags partition by zeroes and then rewrote back with proper data.
Lack of ability flash main (system) partition correct probably still persist.
So don't do this, flash only diags partition.

File are same like before, just run EXE, for compile on 32 bit Windows run make.bat.

Please post feedback.

Poetcop: <waiting for device> message has been deleted before, but now it should appear, if first found device is not Kindle in fastboot.
Hmm... in my case, I verified that windows sees my touch as a fastboot device (1949:d0d0), and I have libusb0.dll installed in c:\windows\system32. But I cannot get past <waiting for device> with your program. I tried running it from a DOS prompt, and in a cygwin shell.

@hostar: How did you test this on your system?

EDIT: Hmm... Now even my linux fastboot that previously worked is stuck at "<waiting for device>", so the problem I am seeing is probably not with your program here... *** Nevermind -- I forgot to do "sudo ./fastboot ...". The linux fastboot still works fine.

Last edited by geekmaster; 03-12-2012 at 10:24 AM.
geekmaster is offline   Reply With Quote