View Single Post
Old 03-03-2012, 12:23 AM   #24
john_pb
Enthusiast
john_pb began at the beginning.
 
Posts: 26
Karma: 10
Join Date: Feb 2012
Device: Kindle Touch
Thank you Geekmaster.

I have read the Fastboot Manifesto thread to get an idea of how to use the tool.

I downloaded and successfully compiled it from yifanlu's git tree on my main Linux PC.

I then used Mfg Tool in Windows XP in VirtualBox to launch into the fastboot mode. So far so good.

However that's where the good news stops. I seem to be having a problem similar to that described by several others on the Fastboot Manifesto thread - namely that when launching the tool on the host Linux PC, it gets stuck on "waiting for device".

Here's where it's at:

The Mfg Tool successfully loads the fastboot profile. At that point, the Kindle disappears from the list of available USB devices in VBox.

Running lsusb on the host PC cannot see the device.
Running dmesg gives the following:

Code:
[13826.928216] usb 1-1: Product: Kindle
[13826.928221] usb 1-1: Manufacturer: Amazon
[13826.928225] usb 1-1: SerialNumber: 00XXXXXX
[13828.288060] usb 1-1: reset high speed USB device number 10 using ehci_hcd
[13828.434124] usb 1-1: USB disconnect, device number 10
[13973.993075] usb 1-1: new high speed USB device number 11 using ehci_hcd
[13974.108477] usb 1-1: New USB device found, idVendor=15a2, idProduct=0052
[13974.108486] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[13974.108494] usb 1-1: Product: NS Blank CODEX 
[13974.108499] usb 1-1: Manufacturer: Freescale SemiConductor Inc 
[13974.109787] generic-usb: probe of 0003:15A2:0052.000C failed with error -22
[13975.733063] usb 1-1: reset high speed USB device number 11 using ehci_hcd
[13976.017075] usb 1-1: reset high speed USB device number 11 using ehci_hcd
[13981.182749] usb 1-1: USB disconnect, device number 11
[13981.416078] usb 1-1: new high speed USB device number 12 using ehci_hcd
[13981.531175] usb 1-1: New USB device found, idVendor=1949, idProduct=d0d0
[13981.531184] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[13981.531191] usb 1-1: Product: Kindle
[13981.531196] usb 1-1: Manufacturer: Amazon
[13981.531201] usb 1-1: SerialNumber: 00XXXXX
[13982.967076] usb 1-1: reset high speed USB device number 12 using ehci_hcd
[13983.113088] usb 1-1: USB disconnect, device number 12
It would seem the device is seen, but is immediately disconnected.

The KT itself is showing the default tree image with no further output.

Clearly I'm doing something wrong. Bummer...!

Last edited by john_pb; 03-03-2012 at 01:00 AM.
john_pb is offline   Reply With Quote