View Single Post
Old 02-25-2012, 11:36 PM   #205
Zatakawa
Enthusiast
Zatakawa ought to be getting tired of karma fortunes by now.Zatakawa ought to be getting tired of karma fortunes by now.Zatakawa ought to be getting tired of karma fortunes by now.Zatakawa ought to be getting tired of karma fortunes by now.Zatakawa ought to be getting tired of karma fortunes by now.Zatakawa ought to be getting tired of karma fortunes by now.Zatakawa ought to be getting tired of karma fortunes by now.Zatakawa ought to be getting tired of karma fortunes by now.Zatakawa ought to be getting tired of karma fortunes by now.Zatakawa ought to be getting tired of karma fortunes by now.Zatakawa ought to be getting tired of karma fortunes by now.
 
Zatakawa's Avatar
 
Posts: 37
Karma: 500222
Join Date: Mar 2011
Device: none
EDIT: Solved. I had to move library_dir out of /home and adjust smarty_dir permissions by executing chown -R www-data:www-data /tmp/smarty_test

Thanks for creating and sharing your server!

I've set up your content server, but when i open index.php, all i get is an Error 500 in Chrome or a blank page in Firefox/Opera. Apache's error.log gives the exact same message which user Eibi got a month ago. How can i troubleshoot this further?

OS: Ubuntu 11.10
Webserver: Apache 2.2.20, PHP 5.3.6-13ubuntu3.6
SQLite3 module enabled, gd support enabled
Smarty 2.6.26.
Smarty seems to work, at least this does not throw an error:
Code:
require_once('Smarty.class.php');
$smarty = new Smarty();
config_local.php:
Code:
...
        $config['library_dir'] = '/home/peter/bib';
	$config['web_dir'] = '.';
	$config['smarty_web_dir'] = $config['web_dir'] . '/smarty';
	$config['smarty_dir'] = '/tmp/smarty_test';
	$config['smarty'] = '/usr/share/php/smarty';
...
If you need any more information, please let me know!

Last edited by Zatakawa; 02-26-2012 at 12:50 AM.
Zatakawa is offline   Reply With Quote