Thread: SSH Help
View Single Post
Old 02-17-2012, 09:34 AM   #56
ixtab
0x2A
ixtab ought to be getting tired of karma fortunes by now.ixtab ought to be getting tired of karma fortunes by now.ixtab ought to be getting tired of karma fortunes by now.ixtab ought to be getting tired of karma fortunes by now.ixtab ought to be getting tired of karma fortunes by now.ixtab ought to be getting tired of karma fortunes by now.ixtab ought to be getting tired of karma fortunes by now.ixtab ought to be getting tired of karma fortunes by now.ixtab ought to be getting tired of karma fortunes by now.ixtab ought to be getting tired of karma fortunes by now.ixtab ought to be getting tired of karma fortunes by now.
 
ixtab's Avatar
 
Posts: 2,903
Karma: 6677427
Join Date: Dec 2011
Device: K3, K4, K5, KPW, KPW2
Well, this:
Quote:
Originally Posted by knc1
If ssh is still not working for you, we need to figure out how to get dropbear to look for the public key(s) under /tmp/* rather than under ~/.ssh
made me think that you didn't get that ~ actually is /tmp/root.

I personally think that it's actually a wiser choice (from Amazon's perspective) to put the root home directory under /tmp/ than to make it persistent. This way, even if something inadvertently shoots itself in the foot, at least such settings are cleared after a reboot. (Though I don't know which kind of setting would qualify here).
ixtab is offline   Reply With Quote