View Single Post
Old 01-10-2012, 02:08 PM   #25
st_albert
Fanatic
st_albert has top level security clearance to Area 51.st_albert has top level security clearance to Area 51.st_albert has top level security clearance to Area 51.st_albert has top level security clearance to Area 51.st_albert has top level security clearance to Area 51.st_albert has top level security clearance to Area 51.st_albert has top level security clearance to Area 51.st_albert has top level security clearance to Area 51.st_albert has top level security clearance to Area 51.st_albert has top level security clearance to Area 51.st_albert has top level security clearance to Area 51.
 
Posts: 548
Karma: 94420
Join Date: Feb 2010
Device: none
I'm using 0.4.905 on Debian Sid with KDE desktop. I uninstalled a previous beta before using the binary installer. "About" reports QT 4.7.2. (NB: the native QT on this box is 4.7.3, so it's using the packaged libraries.)

The "well-formed errors" check doesn't seem to be working right for me. If there's an error in an xhtml file, switching to BV from CV brings up the warning popup message, as it should. However, clicking the "fix manually" button just brings up the warning box again. The only way out seems to be hit "fix automatically" then go back to CV to fix the fix.

To test, I put a <span> at the beginning of a paragraph, without the closing </span>. Automatic fixing did add the </span> at the end of that paragraph, but then it put a <span> ... </span> pair in each following paragraph

I don't know whether it's safer to leave "well formed errors" check disabled (does it still silently auto-fix in that case?) or leave it on ( in which case it needs to allow manual fixing).

FWIW, I am old enough to remember automatic syntax correction in PL/I interpreters on an IBM 360 mainframe. It was a terrible idea then, and I don't think it's gotten any better since. JMHO
st_albert is offline