View Single Post
Old 01-10-2012, 04:11 AM   #21
meme
Sigil developer
meme ought to be getting tired of karma fortunes by now.meme ought to be getting tired of karma fortunes by now.meme ought to be getting tired of karma fortunes by now.meme ought to be getting tired of karma fortunes by now.meme ought to be getting tired of karma fortunes by now.meme ought to be getting tired of karma fortunes by now.meme ought to be getting tired of karma fortunes by now.meme ought to be getting tired of karma fortunes by now.meme ought to be getting tired of karma fortunes by now.meme ought to be getting tired of karma fortunes by now.meme ought to be getting tired of karma fortunes by now.
 
Posts: 1,275
Karma: 1101600
Join Date: Jan 2011
Location: UK
Device: Kindle PW, K4 NT, K3, Kobo Touch
Quote:
Originally Posted by user_none View Post
@meme, are you using the binary installer? Did you also install over an existing install or is this with your source build? I Linux might be having the same issue as Windows.
On Ubuntu 11.10.
Completely removed all traces of sigil including my conf file, source built binaries, translations, etc. Everything I could find with [sS]igil in the name (except of course my source tree )

Re-downloaded 0.4.905 and installed.
Started from Ubuntu desktop icon - The "highlight in BV-switch to CV-highlighted text deleted" bug is NOT there. About version is 0.4.905, QT 4.7.2
Start sigil from command line. Bug is there. About version is 0.4.905 QT 4.7.4. Hmmm.

I was starting sigil from the command line like /opt/sigil/sigil - after checking the desktop icon I see it should be /opt/sigil/sigil.sh as that's setting the LD_LIBRARY_PATH.
Start from /opt/sigil/sigil.sh on command line and it works, QT is 4.7.2 again - the highlighted text is no longer deleted.

Now I just have to work out how to get my build to build with QT 4.7.2 since I think that may fix my minor issue of the right click menu showing Fonts/Direction twice.
meme is offline