View Single Post
Old 01-05-2012, 11:03 AM   #177
hekom
Member
hekom began at the beginning.
 
Posts: 12
Karma: 10
Join Date: Jan 2012
Device: samsung galaxy 10.1
Quote:
Originally Posted by chaley View Post
Sorry, but I know nothing about IIS, so I can't give much help. That said, there are some things to look at.
  • You say the "latest smarty". The server runs with smarty 2.6. I have no idea if it runs with smarty 3.
  • The server has been tested with PHP 5.2 and PHP 5.3. You should verify that you have one of those.
  • Be sure to run PHP as a module and not in CGI mode (assuming IIS can make that distinction).
  • Given that you are using IIS, you might want to change all the '/' characters to '\\'.
  • the values for config web_dir, smarty_dir, and smarty must be real file paths, probably including a drive letter as you are running on IIS. They are specifically *not* URL paths.
  • I don't know what "binded the directory to port 8060" means, so I can't say if doing so overrides any of the above comments.
Hello All

Environment:
- Windows2008 R2; IIS 7.5; PHP 5.3.8; Smarty 2.6.26; pdo_sqlite 3.7.7.1

Config_local:
$config['web_dir'] = 'c:/inetpub/wwwroot/calibre';
$config['smarty_web_dir'] = $config['web_dir'] . '/smarty';
$config['smarty_dir'] = 'c:/tmp';
$config['smarty'] = 'c:/inetpub/wwwroot/calibre/smarty/libs';

IIS user has RW rights on c:\tmp

UPDATE: former Http error 500 is gone... how hard can it be... forgottten to enable the php extension sqlite3.dll in php.ini... ;-)

Now, something else is wrong.. my website displays the template in stead of opening it.
So it displays:
{config_load file=test.conf section="setup"} {include file="header.tpl" title=foo}

{* bold and title are read from the config file *}
{if #bold#}{/if}
{* capitalize the first letters of each word of the title *}
Title: {#title#|capitalize}
{if #bold#}{/if}

The current date and time is {$smarty.now|date_format:"%Y-%m-%d %H:%M:%S"}

etc. etc.


Do I have to change index.tpl ???


thanks
Henny

Last edited by hekom; 01-07-2012 at 09:43 AM.
hekom is offline   Reply With Quote