View Single Post
Old 01-02-2012, 08:50 PM   #26
geekmaster
Всё гениальное просто.
geekmaster ought to be getting tired of karma fortunes by now.geekmaster ought to be getting tired of karma fortunes by now.geekmaster ought to be getting tired of karma fortunes by now.geekmaster ought to be getting tired of karma fortunes by now.geekmaster ought to be getting tired of karma fortunes by now.geekmaster ought to be getting tired of karma fortunes by now.geekmaster ought to be getting tired of karma fortunes by now.geekmaster ought to be getting tired of karma fortunes by now.geekmaster ought to be getting tired of karma fortunes by now.geekmaster ought to be getting tired of karma fortunes by now.geekmaster ought to be getting tired of karma fortunes by now.
 
geekmaster's Avatar
 
Posts: 5,066
Karma: 6789001
Join Date: Nov 2011
Location: Щедрость не имеет пределов.
Device: *.*
Quote:
Originally Posted by sjheiss View Post
No, I'm pretty sure the version in the first post is different than the one from NSLU2's site. He says "The existing versions of OptWare expect a version of wget that supports the "--passive-ftp" option, and the Kindle's BusyBox simply doesn't. Took enough work to fix this that I figured it was worth posting."

And after I installed it and tried running "ipkg update" I get an error involving --passive-ftp:

"ipkg_download: ERROR: Command failed with return value 1: `wget --passive-ftp -q -P /opt/ipkg-NIKtxs http://ipkg.nslu2-linux.org/feeds/op...table/Packages'
...
When following the instructions in the first post on a Kindle 4 (Non Touch), I got the passive-ftp error using the busybox wget in the k4nt main partition.

The busybox built-in commands are intrinsics. The search path is not followed. To execute an external command you must include a path (like ./wget to run an optware wget). Unfortunately, ipgk does not supply this so the wget built into the parent busybox is used instead.

After much experimentation, I mounted the diags partition in /mnt/mmc and ran bash from its busybox, to get rid of the wget problem. That busybox has more commands, and its wget does not get the passive-ftp error when called by ipkg.

Do not make changes in the mounted diags partition. It would probably be a much better idea to download and run a bash shell that does not contain wget, and put the optware wget folder at the beginning of the search path.

Here is the optware bash shell:
http://ipkg.nslu2-linux.org/feeds/op...2.49-1_arm.ipk

Extract data.tar.gz from the .ipk file, then extract data.tar.gz into a bash folder.

Last edited by geekmaster; 01-02-2012 at 09:08 PM.
geekmaster is offline   Reply With Quote