View Single Post
Old 12-28-2011, 05:12 AM   #11
mshnryman
Member
mshnryman began at the beginning.
 
Posts: 16
Karma: 36
Join Date: Mar 2009
Device: Kindle Touch, Nook Simple Touch, Kindle 2, Nook 1st Gen
Thank you for your suggestions and the attached picture!
BTW, what are you using to get that coverflow-esque look?
Quote:
Originally Posted by dwanthny View Post
The problem isn't with how calibre exported the books the problem lies with how you added them back to calibre.
I added them back exactly the way you mentioned. You may be right that it isn't how calibre exported them, but the reason I assumed that is that the export filename is set to {title} - {authors} as the filename for the book, and then when importing the book, the Title comes in exactly as the filename.

Quote:
Originally Posted by dwanthny View Post
The Book Title and Author should not end up in the title field. Under Preferences - Adding books when you want the metadata (ie. Title and Author) to be filled in based on the file name you first have to uncheck the box in front of Read metadata from file contents rather than file name. Unchecking the box will cause the Title and Author fields to be filled in using the file name. The default regex of
Code:
(?P<title>.+) - (?P<author>[^_]+)
should, during the Adding books phase, interpret the files correctly and parse the Title and Author into their respective fields.
My settings were already configured this way when I was re-importing the books back into calibre.


Quote:
Originally Posted by dwanthny View Post
You can make anything as complicated as need be, but in this case the user has to do the basic adding books steps to ensure the title and author are both not in the title field.
I'm open to any ideas that I may have missed, but I already followed your "basic steps" to add books...maybe I missed the step of changing the behavior of "Saving books to disk" to "{title}" instead of "{title} - {authors}" before exporting them all.
mshnryman is offline   Reply With Quote