View Single Post
Old 12-28-2011, 04:37 AM   #9
DoctorOhh
US Navy, Retired
DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.
 
DoctorOhh's Avatar
 
Posts: 8,908
Karma: 12755553
Join Date: Feb 2009
Location: North Carolina
Device: Nexus 7
Moderator Notice
Moved various posts out of Find Duplicates plugin thread as there was no question pertaining to that plugin. If you have specific questions about the Find Duplicates plugins feel free to post those questions in that thread.
Quote:
Originally Posted by mshnryman View Post
So turns out that "Find Duplicates" does work somewhat...its problem is in slightly varying book names because of how Calibre exported them.
The problem isn't with how calibre exported the books the problem lies with how you added them back to calibre.

Quote:
Originally Posted by mshnryman View Post
The book name + author in the title apparently confuses "Find Duplicates" enough that it doesn't consider it a duplicate file.
The Book Title and Author should not end up in the title field. Under Preferences - Adding books when you want the metadata (ie. Title and Author) to be filled in based on the file name you first have to uncheck the box in front of Read metadata from file contents rather than file name. Unchecking the box will cause the Title and Author fields to be filled in using the file name. The default regex of
Code:
(?P<title>.+) - (?P<author>[^_]+)
should, during the Adding books phase, interpret the files correctly and parse the Title and Author into their respective fields.

Getting this step right should allow the auto-merge feature may function as expected, since docx is unsupported I'm not sure if this is the case.

I use the Quick Preferences Plugin (see attached) to easily set the appropriate adding books settings and the appropriate regex for the books I'm adding.

Quote:
Originally Posted by mshnryman View Post
Is there any way to make the search more broad (or another plugin) so that you can get a matching file list and then Alt+M them all? I tried "Identical, Similar, Soundex and Fuzzy" with little success. Also, I have no idea what the "Length" parameter is for...
You can make anything as complicated as need be, but in this case the user has to get the basic adding books steps correct to ensure the title and author are both not in the title field.
Attached Thumbnails
Click image for larger version

Name:	quick_preferences.jpg
Views:	78
Size:	186.8 KB
ID:	80466  

Last edited by DoctorOhh; 12-28-2011 at 05:15 AM. Reason: grammar/clarification
DoctorOhh is offline   Reply With Quote