View Single Post
Old 12-10-2011, 02:37 PM   #173
chaley
"chaley", not "charley"
chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.
 
Posts: 5,030
Karma: 802238
Join Date: Jan 2010
Location: France
Device: Many android devices
Quote:
Originally Posted by ogarcia View Post
The only error is the 404 not found:
2011/12/10 20:11:32 [error] 27913#0: *986 open() "/var/www/books/htdocs/index.php/book_format/3/Linux_Pocket_Guide___Daniel_J__Barrett.pdf" failed (20: Not a directory), client: 192.168.10.6, server: my.server.com, request: "GET /index.php/book_format/3/Linux_Pocket_Guide___Daniel_J__Barrett.pdf HTTP/1.1", host: "my.server.com", referrer: "http://my.server.com/index.php?m=catval&id=PDF&p=1&cat=formats&v=PDF"

And yes, the library_dir contains this folder and the file.

I think that is the translation. The server looks for /index.php/book_format/19/1984___George_Orwell.epub and think that index.php is a folder.

I think that this must be rewrited to something also /index.php?book=book_format/19/1984___George_Orwell.epub to work. But I don't know the rewrite rule.

Can you help me?.

Tanks.
It is not a translation problem. The url must not be rewritten in the form you provide, because doing so will break everything. The server expects that index.php will be executed (as it is with apache servers) and that the rest will be passed as extra components.

Your configuration is clearly different from mine and several others that I know of. Your web server appears to be broken. What versions of what web server and php are you using? Is php a module, or are you using CGI?
chaley is offline   Reply With Quote