View Single Post
Old 11-22-2011, 11:29 AM   #155
chaley
"chaley", not "charley"
chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.
 
Posts: 5,018
Karma: 802238
Join Date: Jan 2010
Location: France
Device: Many android devices
Quote:
Originally Posted by ruaware View Post
I can not get this to work

I have binded the directory to 8060 port so they will goto webaddress and not need a directory. but have also tried adding the folder to an existing settings.

Download latest smarty and placed in /SmartyRelease/libs

I have edit config.local as follows and i just get a blank page. please help
$config['library_dir'] = 'C:\\Users\\jamie\\Calibre Library';
$config['web_dir'] = '/';
$config['smarty_web_dir'] = $config['web_dir'] . '/smarty';
$config['smarty_dir'] = 'C:\Moodle\smartyTemp';
$config['smarty'] = '/SmartyRelease/libs';

edit: forgot to say i have IIS 7.5 and PHP 5.??
Sorry, but I know nothing about IIS, so I can't give much help. That said, there are some things to look at.
  • You say the "latest smarty". The server runs with smarty 2.6. I have no idea if it runs with smarty 3.
  • The server has been tested with PHP 5.2 and PHP 5.3. You should verify that you have one of those.
  • Be sure to run PHP as a module and not in CGI mode (assuming IIS can make that distinction).
  • Given that you are using IIS, you might want to change all the '/' characters to '\\'.
  • the values for config web_dir, smarty_dir, and smarty must be real file paths, probably including a drive letter as you are running on IIS. They are specifically *not* URL paths.
  • I don't know what "binded the directory to port 8060" means, so I can't say if doing so overrides any of the above comments.
chaley is offline   Reply With Quote