View Single Post
Old 10-01-2011, 03:39 PM   #1
Aldebaranian
Junior Member
Aldebaranian can extract oil from cheeseAldebaranian can extract oil from cheeseAldebaranian can extract oil from cheeseAldebaranian can extract oil from cheeseAldebaranian can extract oil from cheeseAldebaranian can extract oil from cheeseAldebaranian can extract oil from cheeseAldebaranian can extract oil from cheeseAldebaranian can extract oil from cheese
 
Posts: 5
Karma: 1126
Join Date: Sep 2011
Device: none
Content server & hierarchical genre - not working?

Hi,

I have followed the general instructions on how to create a hierarchical genre tree (subgroups) in the Calibre manual. This works well, but when I try to share my library using the content server I get an error. I have a fair few genres, so they are collapsed under 'A', 'B' etc.

When I try to open up any of these subtrees under the Genre I get:
Code:
Error: error

createException()@http://192.168.10.3:8080/static/stacktrace.js:81
run(null)@http://192.168.10.3:8080/static/stacktrace.js:66
printStackTrace()@http://192.168.10.3:8080/static/stacktrace.js:57
render_error("error")@http://192.168.10.3:8080/static/browse/browse.js:134
error([object XMLHttpRequest],"error",(void 0))@http://192.168.10.3:8080/static/browse/browse.js:179
handleError([object Object],[object XMLHttpRequest],"error",(void 0))@http://192.168.10.3:8080/static/jquery.js:5304
(?)([object Event])@http://192.168.10.3:8080/static/jquery.js:5210
I thought this must be a well known problem but I can't seem to find other threads with a work-around.

I am just accessing the server locally from Firefox, my machine runs Mac OS X 10.6.8 and Calibre 0.8.21. I started the server from the GUI and there are no error messages in the server logs - the last entry before that error was:

Code:
192.168.10.3 - - [01/Oct/2011:19:30:08] "GET /browse/category_group/ HTTP/1.1" 404 975 "http://192.168.10.3:8080/browse/category/%23genre" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:6.0.2) Gecko/20100101 Firefox/6.0.2"
Anyone have a hint on what I am doing wrong?
Aldebaranian is offline   Reply With Quote