View Single Post
Old 07-17-2011, 12:53 AM   #3
xuyn2003
Connoisseur
xuyn2003 might easily be mistaken for a Texanxuyn2003 might easily be mistaken for a Texanxuyn2003 might easily be mistaken for a Texanxuyn2003 might easily be mistaken for a Texanxuyn2003 might easily be mistaken for a Texanxuyn2003 might easily be mistaken for a Texanxuyn2003 might easily be mistaken for a Texanxuyn2003 might easily be mistaken for a Texanxuyn2003 might easily be mistaken for a Texanxuyn2003 might easily be mistaken for a Texanxuyn2003 might easily be mistaken for a Texan
 
Posts: 71
Karma: 18140
Join Date: Jul 2011
Device: PRS-T1&KOBOTOUCH
Quote:
Originally Posted by Nigol View Post
this is only a guess, but The text file should be encoded as Unicode this is not really a setting you can change. You need to convert your text file encoding. Check in the save dialog in notepad and you will see the encoding drop-box and select Unicode.

For the mobi books, I guess that calibre should convert them to the right encoding, but I can't be sure.

But several person have been able to use other character sets correctly, just make sure it is encoded to Unicode.
Thank you Nigol, I have already saved my txt file as encoded with utf-8, unicode, unicode big endian, and ANSI(according to my pc locale it should be gb2312)
Unfourtunetly, all these four encoded files can't be displayed correctly.

So I guess that Kobo's default encoding method is western(propably iso8859-1),
Why it can render epub correctly is because there are encoding meta data in the epub file's head, this instructed the kobo to use right encoding.
But for the txt documents, with out the encoding meta data, kobo used the default western encoding method.

I'll going to use Calibre to test mobi files.
Thank you!
xuyn2003 is offline   Reply With Quote