View Single Post
Old 03-03-2008, 05:56 PM   #1
jaybee
Enthusiast
jaybee began at the beginning.
 
jaybee's Avatar
 
Posts: 40
Karma: 28
Join Date: Aug 2007
Location: Jackson, TN
Device: iPad Touch PRS-500
libprs500 stopped working on my Mac

After using libprs500 for several months to manage my prs500, suddenly it has stopped. I was using version 4.38. I downloaded and installed the 4.40 with no success. The GUI shows the books loaded on my reader, but not the books in the library. When I tried to add a book to the library, I got this error message:

user-defined aggregate's 'step' method raised error
Detailed traceback:
Traceback (most recent call last):
File "/Applications/Apps in stack/libprs500.app/Contents/Resources/main.py", line 343, in add_books
File "/Applications/Apps in stack/libprs500.app/Contents/Resources/main.py", line 376, in _add_books
File "libprs500/gui2/library.pyo", line 192, in resort
File "libprs500/gui2/library.pyo", line 185, in sort
File "libprs500/library/database.pyo", line 821, in refresh
OperationalError: user-defined aggregate's 'step' method raised error

My Mac is running Leopard: 10.5.2. I believe this problem began after I upgraded the system from 10.5.1 to 10.5.2, but I'm not certain of that.

Is anyone else having this problem? I love the way libprs500 has been working for me. I do have Windows installed on this intel Mac, and if worst comes to worst I can go there, but like many other Mac users I resist "going over to the dark side.
jaybee is offline   Reply With Quote